Skip to content
Open
Show file tree
Hide file tree
Changes from all commits
Commits
File filter

Filter by extension

Filter by extension


Conversations
Failed to load comments.
Loading
Jump to
Jump to file
Failed to load files.
Loading
Diff view
Diff view
2 changes: 1 addition & 1 deletion .github/workflows/agreements.yaml
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@ on:

jobs:
call-workflow-agreements:
uses: splunk/addonfactory-github-workflows/.github/workflows/reusable-agreements.yaml@v1.7.3
uses: splunk/addonfactory-github-workflows/.github/workflows/reusable-agreements.yaml@v1.7.4
permissions:
actions: read
contents: read
Expand Down
14 changes: 7 additions & 7 deletions .github/workflows/build-test-release.yaml
Original file line number Diff line number Diff line change
Expand Up @@ -20,7 +20,7 @@ jobs:
runs-on: ubuntu-latest
steps:
- uses: actions/checkout@v7.0.1
- uses: apache/skywalking-eyes@v0.6.0
- uses: apache/skywalking-eyes@v0.9.0

Copy link
Copy Markdown

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

P1 Badge Pin SkyWalking Eyes to the released v0.8.0 tag

When build-test-release.yaml runs, GitHub must resolve this action before the compliance-copyrights job can execute, but the dependency update and included release notes identify v0.8.0 as the available update while this line references v0.9.0. That unresolved tag causes the compliance job to fail during action setup on every workflow run; use the released v0.8.0 tag.

Useful? React with 👍 / 👎.

env:
GITHUB_TOKEN: ${{ secrets.GITHUB_TOKEN }}

Expand Down Expand Up @@ -49,20 +49,20 @@ jobs:
block_mode: "policy"

pre-commit:
runs-on: ubuntu-22.04
runs-on: ubuntu-26.04
steps:
- uses: actions/checkout@v7.0.1
- uses: actions/setup-python@v6.3.0
- uses: actions/setup-python@v7.1.0
with:
python-version: "3.13"
python-version: "3.15"

Copy link
Copy Markdown

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

P2 Badge Keep the validation job on a supported Python

Fresh evidence in this revision is that the job now selects Python 3.15, while pyproject.toml still declares requires-python = ">=3.9,<3.14"; the subsequent poetry install therefore cannot create the project environment with the selected interpreter and will either substitute an ambient compatible Python or fail to find one. Consequently, the job does not validate 3.15 as configured and may fail on runners lacking a compatible fallback; retain 3.13 or expand the project range and regenerate the lock together. See Poetry's environment configuration.

Useful? React with 👍 / 👎.

- name: Install Poetry
run: python -m pip install poetry==2.2.1
- name: Install repository validation dependencies
run: poetry install --no-root
- name: Run repository unit tests with coverage
run: poetry run pytest
- name: Upload repository coverage report
uses: actions/upload-artifact@v7.0.1
uses: actions/upload-artifact@v7.0.2
with:
name: repository-python-coverage
path: coverage.xml
Expand Down Expand Up @@ -105,7 +105,7 @@ jobs:
- semgrep
runs-on: ubuntu-latest
steps:
- uses: actions/create-github-app-token@v3.2.0
- uses: actions/create-github-app-token@v3.3.0
id: app-token
with:
client-id: ${{ secrets.GH_APP_CLIENT_ID }}
Expand All @@ -130,7 +130,7 @@ jobs:
needs: publish
runs-on: ubuntu-latest
steps:
- uses: actions/create-github-app-token@v3.2.0
- uses: actions/create-github-app-token@v3.3.0
id: app-token
with:
client-id: ${{ secrets.GH_APP_CLIENT_ID }}
Expand Down
Loading
Loading